Vulnerabilities / Event Organiser / WPSEC-2026-1675

Event Organiser <= 3.12.10 - Authenticated (Contributor+) Stored Cross-Site Scripting via %event_thumbnail% Shortcode Template Tag

Medium 6.4 CWE-79Fixed in 3.12.11
ID
WPSEC-2026-1675
Plugin
Event Organiser (event-organiser)
Affected
all versions before 3.12.11
Remediation
Update to 3.12.11 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-27
Attack surface
Event Organiser on WPSec AttackSurface
Fix released
Published

Description

The Event Organiser plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the %event_thumbnail% template tag in the event list shortcode in all versions up to, and including, 3.12.10 due to insufficient input sanitization and output escaping on user-supplied image attributes, which are HTML-entity-decoded and passed into the thumbnail img tag. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0