Vulnerabilities / Booking Package / WPSEC-2026-1688

Booking Package <= 1.7.33 - Authenticated (Booking Package Editor+) Missing Authorization to Settings Update and Calendar Account Deletion

Medium 5.5 CWE-862Fixed in 1.7.34
ID
WPSEC-2026-1688
Plugin
Booking Package (booking-package)
Affected
all versions before 1.7.34
Remediation
Update to 1.7.34 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:L
Weakness
CWE-862
Usage
Plugin Low · Affected versions None seen among sites WPSec scans, 2026-10-27
Attack surface
Booking Package on WPSec AttackSurface
Fix released
Published

Description

The Booking Package plugin for WordPress is vulnerable to unauthorized access via the 'setting', 'updateMemberSetting', 'resetSubscription' and 'deleteCalendarAccount' modes of its admin AJAX handler in all versions up to, and including, 1.7.33, due to the handler allowing every mode to any user with the edit_others_posts capability or the plugin's Booking Package Editor role, without the manager-level capability check these modes need. This makes it possible for authenticated attackers with Editor-level access or the Booking Package Editor role to change the plugin's general and member settings, reset the plugin's subscription data and delete calendar accounts.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0