Minimum and Maximum Quantity for WooCommerce <= 2.1.3 - Missing Authorization to Authenticated (Subscriber+) Freemius Account Opt-In
- ID
- WPSEC-2026-1694
- Plugin
- Minimum and Maximum Quantity for WooCommerce (min-and-max-quantity-for-woocommerce)
- Affected
- all versions before 2.1.4
- Remediation
- Update to 2.1.4 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weakness
- CWE-862
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-27
- Attack surface
- Minimum and Maximum Quantity for WooCommerce on WPSec AttackSurface
- Fix released
- Published
Description
The Minimum and Maximum Quantity for WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data via the bundled Freemius SDK's opt-in handler in all versions up to, and including, 2.1.3, due to a missing capability check in the _install_with_new_user() function. The function runs on admin_menu for any logged-in user. This makes it possible for authenticated attackers, with subscriber-level access and above, to connect a site that has not opted in (for example, one where the administrator skipped the opt-in) to a Freemius account and install of their choosing, and to change its tracking permissions, without administrator consent.
References
- https://wpsec.com/vuln/WPSEC-2026-1694/
- https://plugins.svn.wordpress.org/min-and-max-quantity-for-woocommerce/tags/2.1.4/
- https://wordpress.org/plugins/min-and-max-quantity-for-woocommerce/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS