Minimum and Maximum Quantity for WooCommerce <= 2.1.3 - Cross-Site Request Forgery to Bulk Rule Deletion and Status Change
- ID
- WPSEC-2026-1695
- Plugin
- Minimum and Maximum Quantity for WooCommerce (min-and-max-quantity-for-woocommerce)
- Affected
- all versions before 2.1.4
- Remediation
- Update to 2.1.4 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- Weakness
- CWE-352
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-27
- Attack surface
- Minimum and Maximum Quantity for WooCommerce on WPSec AttackSurface
- Fix released
- Published
Description
The Minimum and Maximum Quantity for WooCommerce plugin for WordPress is vulnerable to Cross-Site Request Forgery via the bulk actions of the Min/Max Rules list in all versions up to, and including, 2.1.3, due to incorrect nonce validation in the process_bulk_action() function. The nonce was checked against an action name the list table never uses, and a failed check did not stop the request. This makes it possible for unauthenticated attackers to delete, enable or disable rules, and to delete or change other posts by ID, via a forged request, if they can trick a site administrator into performing an action such as clicking a link.
References
- https://wpsec.com/vuln/WPSEC-2026-1695/
- https://plugins.svn.wordpress.org/min-and-max-quantity-for-woocommerce/tags/2.1.4/
- https://wordpress.org/plugins/min-and-max-quantity-for-woocommerce/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS