Vulnerabilities / B Slider / WPSEC-2026-1696

B Slider <= 2.2.2 - Authenticated (Author+) Stored Cross-Site Scripting via ACF Field Values

Medium 6.4 CWE-79Fixed in 2.2.4
ID
WPSEC-2026-1696
Plugin
bSlider – Build Sliders That Bring Your Content to Life (b-slider)
Affected
from 2.0.17 before 2.2.4
Remediation
Update to 2.2.4 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-27
Attack surface
B Slider on WPSec AttackSurface
Fix released
Published

Description

The bSlider plugin for WordPress is vulnerable to Stored Cross-Site Scripting via ACF field values shown on post sliders in versions 2.0.17 up to, and including, 2.2.2. The plugin does not sanitize field values and URLs before returning them, and the front-end script renders any value that contains HTML as raw markup. This makes it possible for authenticated attackers, with author-level access and above, to store arbitrary web scripts in the custom field values of their published posts. The scripts run whenever a user opens a page with a slider that displays those fields.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0