Vulnerabilities / B Slider / WPSEC-2026-1697

B Slider <= 2.2.2 - Unauthenticated Sensitive Information Exposure via Posts AJAX ACF Fields

Medium 5.3 CWE-200Fixed in 2.2.4
ID
WPSEC-2026-1697
Plugin
bSlider – Build Sliders That Bring Your Content to Life (b-slider)
Affected
from 2.0.17 before 2.2.4
Remediation
Update to 2.2.4 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-200
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-27
Attack surface
B Slider on WPSec AttackSurface
Fix released
Published

Description

The bSlider plugin for WordPress is vulnerable to Sensitive Information Exposure via the bsbPosts AJAX action in versions 2.0.17 up to, and including, 2.2.2. The handler trusts the ACF field names the browser sends and does not check that the slider block was configured to show them. This makes it possible for unauthenticated attackers to read the values of any ACF field assigned to a public post type on published posts, including fields that were never meant to be displayed. The attacker needs the nonce that the plugin prints on pages containing a post slider.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0