Vulnerabilities / B Slider / WPSEC-2026-1698

B Slider <= 2.2.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via Slider Settings

Medium 6.4 CWE-79Fixed in 2.2.4
ID
WPSEC-2026-1698
Plugin
bSlider – Build Sliders That Bring Your Content to Life (b-slider)
Affected
all versions before 2.2.4
Remediation
Update to 2.2.4 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-27
Attack surface
B Slider on WPSec AttackSurface
Fix released
Published

Description

The bSlider plugin for WordPress is vulnerable to Stored Cross-Site Scripting via slider block settings in all versions up to, and including, 2.2.2. The affected settings include the arrow size and color, the video and image lightbox URLs, the image caption and title, and the button text. The plugin does not sanitize or escape these values before the front-end script inserts them into HTML markup. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0