Vulnerabilities / Slimstat Analytics / WPSEC-2026-1708
Slimstat Analytics <= 5.5.0 - Authenticated (Contributor+) Sensitive Information Exposure via Shortcodes
Medium 4.3
CWE-200Fixed in 6.0.0
- ID
- WPSEC-2026-1708
- Plugin
- SlimStat Analytics (wp-slimstat)
- Affected
- all versions before 6.0.0
- Remediation
- Update to 6.0.0 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-200
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-27
- Attack surface
- Slimstat Analytics on WPSec AttackSurface
- Fix released
- Published
Description
The SlimStat Analytics plugin for WordPress is vulnerable to Sensitive Information Exposure via its shortcodes in all versions up to, and including, 5.5.0 due to the shortcodes displaying personal data, access logs and user reports without verifying that the viewer is allowed to view analytics. This makes it possible for authenticated attackers, with contributor-level access and above, to embed the shortcode in a post and view visitor personal data and access logs they are not authorized to see.
References
- https://wpsec.com/vuln/WPSEC-2026-1708/
- https://plugins.svn.wordpress.org/wp-slimstat/tags/6.0.0/
- https://wordpress.org/plugins/wp-slimstat/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS