Vulnerabilities / Events Manager – Calendar, Bookings, Tickets, Appointments and more! / WPSEC-2026-1712
Events Manager – Calendar, Bookings, Tickets, Appointments and more! <= 7.4.11 - Unauthenticated Sensitive Information Exposure of Pending and Private Locations via Events Map Data Request
Medium 5.3
CWE-200Fixed in 7.4.12
- ID
- WPSEC-2026-1712
- Plugin
- Events Manager – Calendar, Bookings, Tickets, Appointments and more! (events-manager)
- Affected
- all versions before 7.4.12
- Remediation
- Update to 7.4.12 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-200
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-27
- Attack surface
- Events Manager – Calendar, Bookings, Tickets, Appointments and more! on WPSec AttackSurface
- Fix released
- Published
Description
The Events Manager plugin for WordPress is vulnerable to Sensitive Information Exposure via the GlobalEventsMapData map data request in all versions up to, and including, 7.4.11, due to the handler outputting the full record and map balloon of each event's joined location without checking that location's own publication status or visibility. This makes it possible for unauthenticated attackers to retrieve the name, address, coordinates, description and other details of pending, draft and private locations attached to publicly listed events.
References
- https://wpsec.com/vuln/WPSEC-2026-1712/
- https://plugins.svn.wordpress.org/events-manager/tags/7.4.12/
- https://wordpress.org/plugins/events-manager/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS