Vulnerabilities / iChart – Easy Charts and Graphs / WPSEC-2026-1722
iChart – Easy Charts and Graphs <= 2.2.2 - Authenticated (Subscriber+) Missing Authorization to Arbitrary Post Deletion
Medium 6.5
CWE-862Fixed in 2.2.3
- ID
- WPSEC-2026-1722
- Plugin
- iChart – Easy Charts and Graphs (ichart)
- Affected
- all versions before 2.2.3
- Remediation
- Update to 2.2.3 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- Weakness
- CWE-862
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-27
- Attack surface
- iChart – Easy Charts and Graphs on WPSec AttackSurface
- Fix released
- Published
Description
The iChart plugin for WordPress is vulnerable to unauthorized post deletion via the qcld_ai_remove_chart AJAX action in all versions up to, and including, 2.2.2. This is due to a missing capability check and the lack of any post-type restriction on the supplied post ID; only a nonce was verified, and that nonce was exposed to all logged-in users. This makes it possible for authenticated attackers, with Subscriber-level access and above, to permanently delete arbitrary posts and pages on the site.
References
- https://wpsec.com/vuln/WPSEC-2026-1722/
- https://plugins.svn.wordpress.org/ichart/tags/2.2.3/
- https://wordpress.org/plugins/ichart/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS