Content Slider Block – Create fully functional slider with Gutenberg block <= 3.2.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Slide Button Link
- ID
- WPSEC-2026-1725
- Plugin
- Content Slider Block – Bring your content to life with slides (content-slider-block)
- Affected
- all versions before 3.2.2
- Remediation
- Update to 3.2.2 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-27
- Attack surface
- Content Slider Block – Create fully functional slider with Gutenberg block on WPSec AttackSurface
- Fix released
- Published
Description
The Content Slider Block plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the slide button link (btnLink) attribute of the Content Slider block in all versions up to, and including, 3.2.1. This is due to the block attributes being passed unsanitized from the server to the frontend script, which uses the button link as the href of the slide button without validating its URL scheme, so javascript: URLs are rendered. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute when a user clicks the slide button on an injected page.
References
- https://wpsec.com/vuln/WPSEC-2026-1725/
- https://plugins.svn.wordpress.org/content-slider-block/tags/3.2.2/
- https://wordpress.org/plugins/content-slider-block/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS