Event Manager and Tickets Selling Plugin for WooCommerce <= 5.7.10 - Unauthenticated Sensitive Information Exposure via Event Date, Seat and Stock AJAX Actions
- ID
- WPSEC-2026-1732
- Plugin
- Event Booking Manager for WooCommerce – Sell Tickets, Event Registration, RSVP & Event Calendar (mage-eventpress)
- Affected
- all versions before 5.7.11
- Remediation
- Update to 5.7.11 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-200
- Usage
- Plugin Medium · Affected versions Low among sites WPSec scans, 2026-10-27
- Attack surface
- Event Manager and Tickets Selling Plugin for WooCommerce on WPSec AttackSurface
- Fix released
- Published
Description
The Event Booking Manager for WooCommerce plugin for WordPress is vulnerable to Sensitive Information Exposure via the mep_event_list_date_schedule, mep_change_date_status, mep_change_time_status and mep_calendar_get_event_stock AJAX actions, and via the date-list and seat-status AJAX handlers, in all versions up to, and including, 5.7.10. This is due to the handlers accepting any post ID without checking that it is a published event the visitor may view. This makes it possible for unauthenticated attackers to retrieve the dates, times, seat counts and ticket-type stock details of draft and private events.
References
- https://wpsec.com/vuln/WPSEC-2026-1732/
- https://plugins.svn.wordpress.org/mage-eventpress/tags/5.7.11/
- https://wordpress.org/plugins/mage-eventpress/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS