Event Manager and Tickets Selling Plugin for WooCommerce <= 5.7.10 - Unauthenticated Arbitrary Shortcode Execution via Event Calendar Filter
- ID
- WPSEC-2026-1733
- Plugin
- Event Booking Manager for WooCommerce – Sell Tickets, Event Registration, RSVP & Event Calendar (mage-eventpress)
- Affected
- all versions before 5.7.11
- Remediation
- Update to 5.7.11 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- Weakness
- CWE-94
- Usage
- Plugin Medium · Affected versions Low among sites WPSec scans, 2026-10-27
- Attack surface
- Event Manager and Tickets Selling Plugin for WooCommerce on WPSec AttackSurface
- Fix released
- Published
Description
The Event Booking Manager for WooCommerce plugin for WordPress is vulnerable to arbitrary shortcode execution via the mep_gat_event_calender AJAX action in all versions up to, and including, 5.7.10, due to user-supplied calendar filter values (cat, org, tag, city, country, status and year) being concatenated into a [mep-event-calendar] shortcode string that is passed to do_shortcode(). esc_attr() does not remove square brackets, and the only nonce the action checks is printed to every visitor on the plugin's front-end pages. This makes it possible for unauthenticated attackers to close the shortcode tag early and execute arbitrary shortcodes registered on the site.
References
- https://wpsec.com/vuln/WPSEC-2026-1733/
- https://plugins.svn.wordpress.org/mage-eventpress/tags/5.7.11/
- https://wordpress.org/plugins/mage-eventpress/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS