Vulnerabilities / Co-Authors Plus / WPSEC-2026-1744

Co-Authors Plus <= 4.1.2 - Authenticated (Contributor+) Missing Authorization to Guest Author Account Linking

Medium 4.3 CWE-862Fixed in 4.1.3
ID
WPSEC-2026-1744
Plugin
Co-Authors Plus (co-authors-plus)
Affected
from 3.0 before 4.1.3
Remediation
Update to 4.1.3 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-862
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-27
Attack surface
Co-Authors Plus on WPSec AttackSurface
Fix released
Published

Description

The Co-Authors Plus plugin for WordPress is vulnerable to unauthorized modification of data via the guest author 'linked account' field in all versions up to, and including, 4.1.2, due to a missing capability check when a guest author is saved. Guest authors use the default post capabilities, and the add-guest-author capability defaults to edit_posts. This makes it possible for authenticated attackers with Contributor-level access and above to create or edit a guest author linked to any WordPress user account. The guest author then replaces that user on bylines across the site, showing the attacker's chosen name, biography and website.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0