Vulnerabilities / Flipbox / WPSEC-2026-1756
Flipbox <= 1.4.0 - Authenticated (Contributor+) Site-Wide CSS Injection via Reusable Block 'ref'
Medium 5.4
CWE-74Fixed in 1.4.1
- ID
- WPSEC-2026-1756
- Plugin
- Flipbox (flipbox)
- Affected
- from 1.2.2 before 1.4.1
- Remediation
- Update to 1.4.1 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- Weakness
- CWE-74
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-27
- Attack surface
- Flipbox on WPSec AttackSurface
- Fix released
- Published
Description
The Flipbox plugin for WordPress is vulnerable to CSS Injection in all versions up to, and including, 1.4.0, due to missing validation of the core/block 'ref' attribute: any post ID was accepted as a reusable block, its block CSS was written to a public stylesheet, and the IDs were saved to a site-wide option whose stylesheets load on every front-end page. This makes it possible for authenticated attackers, with contributor-level access and above, to make CSS from an unpublished draft load on every page of the site, which can be used to deface pages or send page data to another host.
References
- https://wpsec.com/vuln/WPSEC-2026-1756/
- https://plugins.svn.wordpress.org/flipbox/tags/1.4.1/
- https://wordpress.org/plugins/flipbox/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS