Vulnerabilities / WP GPX Maps / WPSEC-2026-1769

WP GPX Maps <= 1.7.11 - Cross-Site Request Forgery to GPX File Upload

Medium 4.3 CWE-352Fixed in 1.8.00
ID
WPSEC-2026-1769
Plugin
WP GPX Maps (wp-gpx-maps)
Affected
all versions before 1.8.00
Remediation
Update to 1.8.00 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
Weakness
CWE-352
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-27
Attack surface
WP GPX Maps on WPSec AttackSurface
Fix released
Published

Description

The WP GPX Maps plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.7.11. This is due to missing nonce validation on the GPX file upload handler in the Tracks tab. This makes it possible for unauthenticated attackers to upload GPX files to the site via a forged request, granted they can trick a site administrator or other user with access to the plugin's Tracks page into performing an action such as clicking on a link.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0