File Manager Pro – Filester <= 2.1.4 - Authenticated (Administrator+) Missing Authorization to Arbitrary Plugin Installation and Activation
- ID
- WPSEC-2026-1784
- Plugin
- File Manager Pro – Filester (filester)
- Affected
- all versions before 2.1.5
- Remediation
- Update to 2.1.5 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
- Weakness
- CWE-862
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-27
- Attack surface
- File Manager Pro – Filester on WPSec AttackSurface
- Fix released
- Published
Description
The Filester plugin for WordPress is vulnerable to unauthorized plugin installation and activation via the yay_recommended_upgrade_plugin and yay_recommended_activate_plugin AJAX actions in all versions up to, and including, 2.1.4 due to a missing capability check; the handlers only verify a nonce. The nonce is exposed on the Recommended Plugins page, which requires manage_options. On multisite installations this makes it possible for authenticated site administrators, who lack the install_plugins and activate_plugins capabilities, to install plugins from arbitrary package URLs and activate them. This can lead to remote code execution.
References
- https://wpsec.com/vuln/WPSEC-2026-1784/
- https://plugins.svn.wordpress.org/filester/tags/2.1.5/
- https://wordpress.org/plugins/filester/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS