Vulnerabilities / Mang Board / WPSEC-2026-1793
Mang Board <= 2.4.6 - Reflected Cross-Site Scripting via 'category1' Parameter
Medium 6.1
CWE-79Fixed in 2.4.7
- ID
- WPSEC-2026-1793
- Plugin
- Mang Board (mangboard)
- Affected
- all versions before 2.4.7
- Remediation
- Update to 2.4.7 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-10-27
- Attack surface
- Mang Board on WPSec AttackSurface
- Fix released
- Published
Description
The Mang Board plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'category1' parameter in all versions up to, and including, 2.4.6, due to insufficient input sanitization and output escaping. On the plugin's admin settings and user list screens, the value is placed unescaped into the onclick attribute of the modify button. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user, such as an administrator, into performing an action such as clicking on a link.
References
- https://wpsec.com/vuln/WPSEC-2026-1793/
- https://plugins.svn.wordpress.org/mangboard/tags/2.4.7/
- https://wordpress.org/plugins/mangboard/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS