The Plus Addons for Elementor <= 6.5.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via Video Player Widget
- ID
- WPSEC-2026-1795
- Plugin
- The Plus Addons for Elementor – Mega Menu, Header Footer, Post Grid, AI Widgets & Templates (the-plus-addons-for-elementor-page-builder)
- Affected
- all versions before 6.6.0
- Remediation
- Update to 6.6.0 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-27
- Attack surface
- The Plus Addons for Elementor on WPSec AttackSurface
- Fix released
- Published
Description
The The Plus Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Video Player widget's YouTube ID, Vimeo ID and MP4 link settings in all versions up to, and including, 6.5.3, due to insufficient input sanitization. esc_attr() and esc_url() keep HTML entities such as encoded quotes, and the lightbox script reads the decoded link and concatenates it into iframe markup. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute when a user clicks the video on an injected page.
References
- https://wpsec.com/vuln/WPSEC-2026-1795/
- https://plugins.svn.wordpress.org/the-plus-addons-for-elementor-page-builder/tags/6.6.0/
- https://wordpress.org/plugins/the-plus-addons-for-elementor-page-builder/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS