The Plus Addons for Elementor <= 6.5.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via Number Counter Widget
- ID
- WPSEC-2026-1796
- Plugin
- The Plus Addons for Elementor – Mega Menu, Header Footer, Post Grid, AI Widgets & Templates (the-plus-addons-for-elementor-page-builder)
- Affected
- all versions before 6.6.0
- Remediation
- Update to 6.6.0 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-27
- Attack surface
- The Plus Addons for Elementor on WPSec AttackSurface
- Fix released
- Published
Description
The The Plus Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Number Counter widget's minimum, maximum, delay and increment number settings in all versions up to, and including, 6.5.3, due to the values not being validated as numbers before being placed in data attributes that the frontend counter script reads back, inserts with .html() and passes to eval(). This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
References
- https://wpsec.com/vuln/WPSEC-2026-1796/
- https://plugins.svn.wordpress.org/the-plus-addons-for-elementor-page-builder/tags/6.6.0/
- https://wordpress.org/plugins/the-plus-addons-for-elementor-page-builder/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS