The Plus Addons for Elementor <= 6.5.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via Syntax Highlighter and Page Scroll Widgets

Medium 6.4 CWE-79Fixed in 6.6.0
ID
WPSEC-2026-1799
Plugin
The Plus Addons for Elementor – Mega Menu, Header Footer, Post Grid, AI Widgets & Templates (the-plus-addons-for-elementor-page-builder)
Affected
all versions before 6.6.0
Remediation
Update to 6.6.0 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-27
Attack surface
The Plus Addons for Elementor on WPSec AttackSurface
Fix released
Published

Description

The The Plus Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Syntax Highlighter widget's copy and copied button labels and the Page Scroll widget's navigation dot tooltips and section anchors in all versions up to, and including, 6.5.3, due to insufficient input sanitization and output escaping. The shared sanitizer removed only hexadecimal entities, so encoded markup passed it, and esc_html()/esc_attr() do not double-encode existing entities, so the browser decoded the data attributes back into markup, which the frontend scripts then inserted as HTML. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0