Vulnerabilities / AI Engine / WPSEC-2026-1804
AI Engine <= 3.8.7 - Unauthenticated IP Address Spoofing via Forwarded HTTP Headers
Medium 5.3
CWE-348Fixed in 3.8.8
- ID
- WPSEC-2026-1804
- Plugin
- AI Engine – MCP Server & AI Chatbot for WordPress, with Claude, ChatGPT & Gemini (ai-engine)
- Affected
- all versions before 3.8.8
- Remediation
- Update to 3.8.8 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- Weakness
- CWE-348
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-28
- Attack surface
- AI Engine on WPSec AttackSurface
- Fix released
- Published
Description
The AI Engine plugin for WordPress is vulnerable to IP Address Spoofing in all versions up to, and including, 3.8.7, due to the get_ip_address() function trusting client-supplied headers such as X-Forwarded-For, Client-IP and X-Real-IP before REMOTE_ADDR, without checking that the request came through a trusted proxy. This makes it possible for unauthenticated attackers to present any IP address they choose, and so get around IP-based restrictions such as the Banned IPs setting and per-IP rate limits, and to falsify the IP address recorded with discussions.
References
- https://wpsec.com/vuln/WPSEC-2026-1804/
- https://plugins.svn.wordpress.org/ai-engine/tags/3.8.8/
- https://wordpress.org/plugins/ai-engine/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS