Vulnerabilities / AI Engine / WPSEC-2026-1805

AI Engine <= 3.8.7 - Authenticated (Subscriber+) Protected Upload File Disclosure via Public API Vision and Transcription Queries

Low 3.1 CWE-552Fixed in 3.8.8
ID
WPSEC-2026-1805
Plugin
AI Engine – MCP Server & AI Chatbot for WordPress, with Claude, ChatGPT & Gemini (ai-engine)
Affected
all versions before 3.8.8
Remediation
Update to 3.8.8 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-552
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-28
Attack surface
AI Engine on WPSec AttackSurface
Fix released
Published

Description

The AI Engine plugin for WordPress is vulnerable to Sensitive Information Exposure via the 'url' parameter of the Public API simpleVisionQuery and simpleTranscribeAudio REST endpoints in all versions up to, and including, 3.8.7, due to Meow_MWAI_Query_DroppedFile reading any URL on the site's own host under the uploads directory straight from disk, which bypasses web server access rules such as .htaccess protection on upload folders. This makes it possible for authenticated attackers, with Subscriber-level access and above, to have protected uploaded files (for example WooCommerce downloadable product files or form uploads) sent to the configured AI model and to get their contents back in the response. The Public API must be enabled, which it is not by default.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0