Vulnerabilities / Booking Package / WPSEC-2026-1814

Booking Package <= 1.7.34 - Unauthenticated HTML Injection in Notification Emails via 'receivedUri' Parameter

Low 3.4 CWE-80Fixed in 1.7.35
ID
WPSEC-2026-1814
Plugin
Booking Package (booking-package)
Affected
all versions before 1.7.35
Remediation
Update to 1.7.35 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:N/I:L/A:N
Weakness
CWE-80
Usage
Plugin Low · Affected versions None seen among sites WPSec scans, 2026-10-28
Attack surface
Booking Package on WPSec AttackSurface
Fix released
Published

Description

The Booking Package plugin for WordPress is vulnerable to HTML Injection via the 'receivedUri' parameter of the public booking submission in all versions up to, and including, 1.7.34, due to the raw, unsanitized request value being substituted for the [receivedUri] and [receivedUrl] placeholders of booking notification emails. This makes it possible for unauthenticated attackers to inject arbitrary HTML, such as phishing links, into notification emails that the site sends to the booking's e-mail address and to the site administrator. Exploitation requires the notification to use the HTML email format, which is not the default, and its template to contain one of these placeholders.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0