Vulnerabilities / SureDash – Community, Courses & Member Dashboard / WPSEC-2026-1829
SureDash – Community, Courses & Member Dashboard <= 1.12.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'formHeadingTag' Block Attribute
Medium 6.4
CWE-79Fixed in 1.12.4
- ID
- WPSEC-2026-1829
- Plugin
- SureDash – Community, Courses & Member Dashboard (suredash)
- Affected
- all versions before 1.12.4
- Remediation
- Update to 1.12.4 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-28
- Attack surface
- SureDash – Community, Courses & Member Dashboard on WPSec AttackSurface
- Fix released
- Published
Description
The SureDash plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'formHeadingTag' attribute of the Login and Register blocks in all versions up to, and including, 1.12.3, due to the attribute being output as the heading's HTML tag name with only esc_attr() applied and no allowlist of tag names. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
References
- https://wpsec.com/vuln/WPSEC-2026-1829/
- https://plugins.svn.wordpress.org/suredash/tags/1.12.4/
- https://wordpress.org/plugins/suredash/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS