Vulnerabilities / SureDash – Community, Courses & Member Dashboard / WPSEC-2026-1831
SureDash – Community, Courses & Member Dashboard <= 1.12.3 - Authenticated (Subscriber+) Arbitrary Shortcode Execution via Comment Content
Medium 6.3
CWE-94Fixed in 1.12.4
- ID
- WPSEC-2026-1831
- Plugin
- SureDash – Community, Courses & Member Dashboard (suredash)
- Affected
- all versions before 1.12.4
- Remediation
- Update to 1.12.4 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- Weakness
- CWE-94
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-28
- Attack surface
- SureDash – Community, Courses & Member Dashboard on WPSec AttackSurface
- Fix released
- Published
Description
The SureDash plugin for WordPress is vulnerable to Arbitrary Shortcode Execution via comment content in the user profile comments listing in all versions up to, and including, 1.12.3, due to the listing passing the stored comment content through do_shortcode() without neutralizing shortcode brackets. Comments stored outside the plugin's own comment endpoint, or before brackets were escaped on submission, keep their shortcodes. This makes it possible for authenticated attackers, with subscriber-level access and above, to execute arbitrary shortcodes.
References
- https://wpsec.com/vuln/WPSEC-2026-1831/
- https://plugins.svn.wordpress.org/suredash/tags/1.12.4/
- https://wordpress.org/plugins/suredash/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS