MasterStudy LMS WordPress Plugin – for Online Courses and Education <= 3.7.55 - Unauthenticated Limited Local File Inclusion via 'params' Parameter
- ID
- WPSEC-2026-1835
- Plugin
- MasterStudy LMS WordPress Plugin – for Online Courses and Education (masterstudy-lms-learning-management-system)
- Affected
- all versions before 3.7.56
- Remediation
- Update to 3.7.56 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
- Weakness
- CWE-98
- Usage
- Plugin Medium · Affected versions Low among sites WPSec scans, 2026-10-28
- Attack surface
- MasterStudy LMS WordPress Plugin – for Online Courses and Education on WPSec AttackSurface
- Fix released
- Published
Description
The MasterStudy LMS WordPress Plugin plugin for WordPress is vulnerable to Limited Local File Inclusion via the 'params' parameter of the stm_lms_load_modal AJAX action in all versions up to, and including, 3.7.55. This is due to the action being registered for unauthenticated users with a nonce printed on every front-end page, and the decoded 'params' array being passed to extract() in STM_LMS_Templates::load_lms_template(), so a 'template_name' key overwrites the template being loaded. This makes it possible for unauthenticated attackers to include and render any PHP template in the plugin's (or theme's) stm-lms-templates directory with variables they choose. For example, they can render the course player lesson template for any lesson ID and read paid or unpublished lesson content. Directory traversal outside the template directory is blocked.
References
- https://wpsec.com/vuln/WPSEC-2026-1835/
- https://plugins.svn.wordpress.org/masterstudy-lms-learning-management-system/tags/3.7.56/
- https://wordpress.org/plugins/masterstudy-lms-learning-management-system/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS