Vulnerabilities / Admin Columns / WPSEC-2026-1839

Admin Columns <= 7.1.7 - Unauthenticated Stored Cross-Site Scripting via Comment User-Agent and Tooltip Content

High 7.2 CWE-79Fixed in 7.1.8
ID
WPSEC-2026-1839
Plugin
Admin Columns (codepress-admin-columns)
Affected
all versions before 7.1.8
Remediation
Update to 7.1.8 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions None seen among sites WPSec scans, 2026-10-28
Attack surface
Admin Columns on WPSec AttackSurface
Fix released
Published

Description

The Admin Columns plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the comment Agent (comment_agent) column and list table tooltips in all versions up to, and including, 7.1.7. This is due to the plugin's list-table tooltip script writing data-ac-tip values into the page with innerHTML, and to insufficient output escaping of the stored comment user agent. Column values are only passed through wp_kses with the 'post' allowlist, which keeps data-* attributes. This makes it possible for unauthenticated attackers who can submit comments to inject arbitrary web scripts through the User-Agent header, and for authenticated attackers with contributor-level access and above to inject them through content they control that is shown in an Admin Columns column, such as a custom field column set to the HTML field type. The scripts run when an administrator loads the list table; for the User-Agent, when the Comments list shows the Agent column.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0