Vulnerabilities / GeoDirectory / WPSEC-2026-1852

GeoDirectory <= 2.8.197 - Authenticated (Subscriber+) Server-Side Request Forgery via Listing File Field URLs

Medium 6.4 CWE-918Fixed in 2.8.198
ID
WPSEC-2026-1852
Plugin
GeoDirectory – WP Business Directory Plugin and Classified Listings Directory (geodirectory)
Affected
all versions before 2.8.198
Remediation
Update to 2.8.198 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-918
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-28
Attack surface
GeoDirectory on WPSec AttackSurface
Fix released
Published

Description

The GeoDirectory plugin for WordPress is vulnerable to Server-Side Request Forgery via external URLs submitted in listing image and file fields in all versions up to, and including, 2.8.197, due to the GeoDir_Media::download_url() function checking only the first host with geodir_is_safe_host() and then fetching the URL with wp_remote_get(), which follows HTTP redirects without checking where they lead. This makes it possible for authenticated attackers, with subscriber-level access and above, to make web requests to arbitrary locations from the web application, including loopback and internal network addresses, by submitting a URL that redirects to them.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0