Vulnerabilities / VikRentCar Car Rental Management System / WPSEC-2026-1855
VikRentCar Car Rental Management System <= 1.4.10 - Unauthenticated Stored Cross-Site Scripting via Booking Optionals
High 7.2
CWE-79Fixed in 1.4.11
- ID
- WPSEC-2026-1855
- Plugin
- VikRentCar Car Rental Management System (vikrentcar)
- Affected
- all versions before 1.4.11
- Remediation
- Update to 1.4.11 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-28
- Attack surface
- VikRentCar Car Rental Management System on WPSec AttackSurface
- Fix released
- Published
Description
The VikRentCar Car Rental Management System plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the optionals (car options) data submitted in the front-end booking flow in all versions up to, and including, 1.4.10. This is due to insufficient input sanitization of the submitted option id:quantity pairs and missing output escaping when the stored quantity is rendered in the administrator's edit-booking view. This makes it possible for unauthenticated attackers to inject arbitrary web scripts that execute whenever an administrator opens the affected booking.
References
- https://wpsec.com/vuln/WPSEC-2026-1855/
- https://plugins.svn.wordpress.org/vikrentcar/tags/1.4.11/
- https://wordpress.org/plugins/vikrentcar/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS