Vulnerabilities / Quick Event Manager / WPSEC-2026-1868
Quick Event Manager <= 9.18 - Unauthenticated Sensitive Information Exposure via Calendar (.ics) Download
Medium 5.3
CWE-200Fixed in 9.19
- ID
- WPSEC-2026-1868
- Plugin
- Quick Event Manager (quick-event-manager)
- Affected
- all versions before 9.19
- Remediation
- Update to 9.19 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-200
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-28
- Attack surface
- Quick Event Manager on WPSec AttackSurface
- Fix released
- Published
Description
The Quick Event Manager plugin for WordPress is vulnerable to Sensitive Information Exposure via the calendar (.ics) download AJAX action in all versions up to, and including, 9.18. This is due to the download not checking the post type or status of the requested ID; its only check is a nonce that is printed publicly wherever the ICS button is shown. This makes it possible for unauthenticated attackers to retrieve the titles of arbitrary posts and the details of unpublished events, including draft and private ones.
References
- https://wpsec.com/vuln/WPSEC-2026-1868/
- https://plugins.svn.wordpress.org/quick-event-manager/tags/9.19/
- https://wordpress.org/plugins/quick-event-manager/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS