Vulnerabilities / WP Document Revisions / WPSEC-2026-1873
WP Document Revisions <= 5.8.1 - Unauthenticated Sensitive Information Exposure via REST API Document Taxonomy Term Counts
Medium 5.3
CWE-200Fixed in 5.8.2
- ID
- WPSEC-2026-1873
- Plugin
- WP Document Revisions (wp-document-revisions)
- Affected
- all versions before 5.8.2
- Remediation
- Update to 5.8.2 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-200
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-28
- Attack surface
- WP Document Revisions on WPSec AttackSurface
- Fix released
- Published
Description
The WP Document Revisions plugin for WordPress is vulnerable to Sensitive Information Exposure via the REST API term endpoints for document taxonomies in all versions up to, and including, 5.8.1. This is due to term counts, as well as the hide_empty and orderby=count query options, being based on counts that include draft, pending and private documents. This makes it possible for unauthenticated attackers to determine how many non-public documents carry each workflow state or custom document taxonomy term, and which terms are used only by non-public documents.
References
- https://wpsec.com/vuln/WPSEC-2026-1873/
- https://plugins.svn.wordpress.org/wp-document-revisions/tags/5.8.2/
- https://wordpress.org/plugins/wp-document-revisions/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS