Vulnerabilities / wp-Typography / WPSEC-2026-1875

wp-Typography <= 5.11.0 - Unauthenticated Stored Cross-Site Scripting via Comments and Post Content

High 7.2 CWE-79Fixed in 5.12.0
ID
WPSEC-2026-1875
Plugin
wp-Typography (wp-typography)
Affected
all versions before 5.12.0
Remediation
Update to 5.12.0 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-28
Attack surface
wp-Typography on WPSec AttackSurface
Fix released
Published

Description

The wp-Typography plugin for WordPress is vulnerable to Stored Cross-Site Scripting via text processed by its typography engine, such as comment text, post content, excerpts and titles, in all versions up to, and including, 5.11.0. This is due to insufficient escaping of the plugin's internal HTML placeholder markers. When a text node is changed by a typography fix, the plugin turns every marker it finds into a literal '<' or '>' and parses the result as HTML. Markers that a user typed as plain text are converted too, so they become real HTML elements and attributes after kses filtering has already run. This makes it possible for unauthenticated attackers (through comments) and authenticated attackers with contributor-level access and above (through post content) to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0