Vulnerabilities / GoodMeet / WPSEC-2026-1876
GoodMeet <= 2.1.1 - Authenticated (Contributor+) Missing Authorization to Meeting Creation
Medium 4.3
CWE-862Fixed in 2.2.0
- ID
- WPSEC-2026-1876
- Plugin
- GoodMeet – Meetings & Classes for Google Meet (goodmeet)
- Affected
- all versions before 2.2.0
- Remediation
- Update to 2.2.0 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weakness
- CWE-862
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-28
- Attack surface
- GoodMeet on WPSec AttackSurface
- Fix released
- Published
Description
The GoodMeet plugin for WordPress is vulnerable to unauthorized access via the goodmeet/v1/meetings REST routes in all versions up to, and including, 2.1.1, due to the routes' permission callback checking only the edit_posts capability. This makes it possible for authenticated attackers, with Contributor-level access and above, to create meetings. Each meeting is published as a public page and creates a live event, with attendees the attacker chooses, on the site owner's connected Google Calendar account. Contributors are normally not allowed to publish content.
References
- https://wpsec.com/vuln/WPSEC-2026-1876/
- https://plugins.svn.wordpress.org/goodmeet/tags/2.2.0/
- https://wordpress.org/plugins/goodmeet/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS