bbPress <= 2.6.20 - Unauthenticated Sensitive Information Exposure via Password-Protected Forum Content
- ID
- WPSEC-2026-1878
- Plugin
- bbPress (bbpress)
- Affected
- all versions before 2.6.21
- Remediation
- Update to 2.6.21 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-200
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-28
- Attack surface
- bbPress on WPSec AttackSurface
- Fix released
- Published
Description
The bbPress plugin for WordPress is vulnerable to Sensitive Information Exposure via site search and WordPress-rendered content in all versions up to, and including, 2.6.20, due to passwords set on forums and topics not being applied to their child content. Search queries did not exclude topics and replies inside password-protected forums or topics, and WordPress's own post_password_required() check, used by core content, excerpt and feed rendering, only considered a post's own password and not the password inherited from its parent topic or forum. This makes it possible for unauthenticated attackers to probe password-protected content with search terms, see the titles of topics and replies inside protected forums and topics, and read that content through WordPress-rendered paths without knowing the password.
References
- https://wpsec.com/vuln/WPSEC-2026-1878/
- https://plugins.svn.wordpress.org/bbpress/tags/2.6.21/
- https://wordpress.org/plugins/bbpress/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS