Vulnerabilities / bbPress / WPSEC-2026-1879

bbPress <= 2.6.20 - Unauthenticated Sensitive Information Exposure via Old-Slug and Canonical Redirects

Medium 5.3 CWE-200Fixed in 2.6.21
ID
WPSEC-2026-1879
Plugin
bbPress (bbpress)
Affected
all versions before 2.6.21
Remediation
Update to 2.6.21 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-200
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-28
Attack surface
bbPress on WPSec AttackSurface
Fix released
Published

Description

The bbPress plugin for WordPress is vulnerable to Sensitive Information Exposure via old-slug, canonical and 404 permalink-guessing redirects in all versions up to, and including, 2.6.20, due to the restricted-post check on canonical redirects only considering the 'p' query variable, old-slug redirects not checking read access, and permalink guessing only being disabled for fully resolved bbPress routes. This makes it possible for unauthenticated attackers to use the 'page_id', 'attachment_id' or 'subpost_id' parameters, old slugs, or malformed bbPress route URLs to be redirected to the permalinks of topics and replies in private or hidden forums, revealing their slugs and titles.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0