Vulnerabilities / WP Travel – Ultimate Travel Booking System, Tour Management Engine / WPSEC-2026-1890
WP Travel – Ultimate Travel Booking System, Tour Management Engine <= 12.0.4 - Authenticated (Editor+) Missing Authorization to Plugin Settings Import and Export
Medium 5.5
CWE-862Fixed in 12.1.0
- ID
- WPSEC-2026-1890
- Plugin
- WP Travel – Ultimate Travel Booking System, Tour Management Engine (wp-travel)
- Affected
- all versions before 12.1.0
- Remediation
- Update to 12.1.0 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:H/A:N
- Weakness
- CWE-862
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-10-29
- Attack surface
- WP Travel – Ultimate Travel Booking System, Tour Management Engine on WPSec AttackSurface
- Fix released
- Published
Description
The WP Travel plugin for WordPress is vulnerable to unauthorized modification of data in all versions up to, and including, 12.0.4 due to the settings import/export REST endpoints' permission callback only checking for the edit_others_posts capability. This makes it possible for authenticated attackers, with Editor-level access and above, to export the plugin's settings and to import arbitrary plugin-wide settings, such as payment configuration, which is normally restricted to administrators.
References
- https://wpsec.com/vuln/WPSEC-2026-1890/
- https://plugins.svn.wordpress.org/wp-travel/tags/12.1.0/
- https://wordpress.org/plugins/wp-travel/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS