Vulnerabilities / Category Slider for WooCommerce / WPSEC-2026-1897
Category Slider for WooCommerce <= 1.7.2 - Cross-Site Request Forgery to WooCommerce Plugin Installation and Activation
Medium 4.3
CWE-352Fixed in 1.7.3
- ID
- WPSEC-2026-1897
- Plugin
- Product Category Slider & Grid for WooCommerce – Reno Product Category (woo-category-slider-grid)
- Affected
- all versions before 1.7.3
- Remediation
- Update to 1.7.3 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- Weakness
- CWE-352
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-29
- Attack surface
- Category Slider for WooCommerce on WPSec AttackSurface
- Fix released
- Published
Description
The Product Category Slider & Grid for WooCommerce plugin for WordPress is vulnerable to Cross-Site Request Forgery via the 'sp-wcsp-woo' query parameter in all versions up to, and including, 1.7.2, due to missing nonce validation in the admin_notice() function. This makes it possible for unauthenticated attackers to install and activate the WooCommerce plugin by tricking a site administrator into clicking a link.
References
- https://wpsec.com/vuln/WPSEC-2026-1897/
- https://plugins.svn.wordpress.org/woo-category-slider-grid/tags/1.7.3/
- https://wordpress.org/plugins/woo-category-slider-grid/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS