WPFunnels – Funnel Builder for WooCommerce with Checkout & One Click Upsell <= 3.13.5 - Unauthenticated Price Manipulation via Upsell/Downsell Offer Acceptance
- ID
- WPSEC-2026-1901
- Plugin
- WPFunnels – Funnel Builder for WooCommerce with Checkout & One Click Upsell (wpfunnels)
- Affected
- all versions before 3.13.6
- Remediation
- Update to 3.13.6 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- Weakness
- CWE-472
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-29
- Attack surface
- WPFunnels – Funnel Builder for WooCommerce with Checkout & One Click Upsell on WPSec AttackSurface
- Fix released
- Published
Description
The WPFunnels plugin for WordPress is vulnerable to price manipulation via the upsell and downsell offer acceptance flow in all versions up to, and including, 3.13.5 due to the product ID, quantity and variation attributes being taken from the request instead of the product configured on the offer step, and to missing checks that the step belongs to the order's funnel and has not already been accepted. This makes it possible for unauthenticated attackers placing an order as a guest customer to apply an offer step's discount (up to 100%) to any catalog product at any quantity, to change which product the offer line item points to, and to accept the same offer repeatedly.
References
- https://wpsec.com/vuln/WPSEC-2026-1901/
- https://plugins.svn.wordpress.org/wpfunnels/tags/3.13.6/
- https://wordpress.org/plugins/wpfunnels/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS