Vulnerabilities / EventPrime / WPSEC-2026-1914

EventPrime <= 4.3.6.0 - Authenticated (Subscriber+) Insecure Direct Object Reference to Arbitrary Ticket and Ticket Category Deletion via Event Submission

Medium 4.3 CWE-639Fixed in 4.3.6.1
ID
WPSEC-2026-1914
Plugin
EventPrime – Events Calendar, Bookings, Tickets & AI (eventprime-event-calendar-management)
Affected
all versions before 4.3.6.1
Remediation
Update to 4.3.6.1 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-639
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-29
Attack surface
EventPrime on WPSec AttackSurface
Fix released
Published

Description

The EventPrime plugin for WordPress is vulnerable to Insecure Direct Object Reference via the 'em_ticket_category_delete_ids' and 'em_ticket_individual_delete_ids' parameters of the frontend event submission (ep_save_frontend_event_submission AJAX action) and event save routines in all versions up to, and including, 4.3.6.0, due to missing validation that the ticket or ticket category IDs requested for deletion belong to the event being saved. This makes it possible for authenticated attackers, with subscriber-level access and above who are permitted to submit events (or unauthenticated attackers when anonymous event submission is enabled), to delete the tickets and ticket categories of any other event.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0