Vulnerabilities / Kali Forms — Contact Form & Drag-and-Drop Builder / WPSEC-2026-1924
Kali Forms — Contact Form & Drag-and-Drop Builder <= 2.4.27 - Authenticated (Contributor+) Sensitive Information Exposure via Form Entries List
Medium 4.3
CWE-200Fixed in 2.4.28
- ID
- WPSEC-2026-1924
- Plugin
- Kali Forms — Contact Form & Drag-and-Drop Builder (kali-forms)
- Affected
- all versions before 2.4.28
- Remediation
- Update to 2.4.28 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-200
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-29
- Attack surface
- Kali Forms — Contact Form & Drag-and-Drop Builder on WPSec AttackSurface
- Fix released
- Published
Description
The Kali Forms plugin for WordPress is vulnerable to Sensitive Information Exposure via the form entries admin list in all versions up to, and including, 2.4.27, due to the kaliforms_submitted post type being registered with the default post capabilities instead of an administrator-only capability. This makes it possible for authenticated attackers, with contributor-level access and above, to list form entries and read their submitted field values, which may contain personal data from site visitors.
References
- https://wpsec.com/vuln/WPSEC-2026-1924/
- https://plugins.svn.wordpress.org/kali-forms/tags/2.4.28/
- https://wordpress.org/plugins/kali-forms/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS