Kali Forms — Contact Form & Drag-and-Drop Builder <= 2.4.27 - Authenticated (Contributor+) Stored Cross-Site Scripting via Form Field Components
- ID
- WPSEC-2026-1925
- Plugin
- Kali Forms — Contact Form & Drag-and-Drop Builder (kali-forms)
- Affected
- from 2.4.21 before 2.4.28
- Remediation
- Update to 2.4.28 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-29
- Attack surface
- Kali Forms — Contact Form & Drag-and-Drop Builder on WPSec AttackSurface
- Fix released
- Published
Description
The Kali Forms plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'kaliforms_field_components' form meta in versions 2.4.21 up to, and including, 2.4.27, due to insufficient input sanitization and output escaping. When the submitted field component JSON could not be decoded, or every field failed sanitization (for example a field with a non-scalar price), the raw submitted JSON was stored unchanged, and the field content and caption HTML was then loaded into the form builder unfiltered. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts that execute when another user, such as an administrator, opens the form in the builder.
References
- https://wpsec.com/vuln/WPSEC-2026-1925/
- https://plugins.svn.wordpress.org/kali-forms/tags/2.4.28/
- https://wordpress.org/plugins/kali-forms/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS