Payment forms, Buy now buttons, and Invoicing System | GetPaid <= 2.8.63 - Missing Authorization to Unauthenticated Sales Report Data Exposure via 'wpi_action' Parameter
- ID
- WPSEC-2026-1926
- Plugin
- Payment forms, Buy now buttons, and Invoicing System | GetPaid (invoicing)
- Affected
- all versions before 2.8.64
- Remediation
- Update to 2.8.64 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-862
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-29
- Attack surface
- Payment forms, Buy now buttons, and Invoicing System | GetPaid on WPSec AttackSurface
- Fix released
- Published
Description
The Payment forms, Buy now buttons, and Invoicing System | GetPaid plugin for WordPress is vulnerable to unauthorized access of data via the 'wpi_action' parameter in all versions up to, and including, 2.8.63. This is due to the wpinv_actions() function, which runs on every request, firing any 'wpinv_'-prefixed action named in the user-supplied 'wpi_action' parameter, while the Reports tab renderer hooked to one of those actions has no capability check. This makes it possible for unauthenticated attackers to render the admin Reports tab and view sales totals per item, per payment method and per discount code, including the discount codes that were used.
References
- https://wpsec.com/vuln/WPSEC-2026-1926/
- https://plugins.svn.wordpress.org/invoicing/tags/2.8.64/
- https://wordpress.org/plugins/invoicing/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS