Vulnerabilities / Kirki / WPSEC-2026-1931

Kirki <= 6.4.0 - Authenticated (Author+) Sensitive Information Exposure of User Email Addresses via User Search

Medium 4.3 CWE-200Fixed in 6.4.1
ID
WPSEC-2026-1931
Plugin
Kirki – Freeform Page Builder, Website Builder & Customizer (kirki)
Affected
from 6.3.2 before 6.4.1
Remediation
Update to 6.4.1 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-200
Usage
Plugin Low · Affected versions None seen among sites WPSec scans, 2026-10-29
Attack surface
Kirki on WPSec AttackSurface
Fix released
Published

Description

The Kirki plugin for WordPress is vulnerable to Sensitive Information Exposure via the user collection, collection and comment mention user search features in all versions up to, and including, 6.4.0, due to the responses including user email addresses and roles, and the searches matching on user_email, without checking the list_users capability. This makes it possible for authenticated attackers with author-level access and above, who have Kirki builder content access by default, or holders of an editor preview link, to obtain or enumerate the email addresses and roles of site users.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0