Vulnerabilities / Kirki / WPSEC-2026-1934

Kirki <= 6.4.0 - Authenticated (Subscriber+) Arbitrary Shortcode Execution via User Profile Fields in Dynamic SEO Values

Medium 4.2 CWE-94Fixed in 6.4.1
ID
WPSEC-2026-1934
Plugin
Kirki – Freeform Page Builder, Website Builder & Customizer (kirki)
Affected
all versions before 6.4.1
Remediation
Update to 6.4.1 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
Weakness
CWE-94
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-29
Attack surface
Kirki on WPSec AttackSurface
Fix released
Published

Description

The Kirki plugin for WordPress is vulnerable to arbitrary shortcode execution via dynamic SEO values in all versions up to, and including, 6.4.0, due to user-editable values such as display names, user profile fields, term names and CMS fields being concatenated into the SEO title and description string that is passed to do_shortcode() without stripping shortcode brackets. This makes it possible for authenticated attackers with subscriber-level access and above to execute arbitrary shortcodes by placing them in their profile fields, when a page's SEO settings use those dynamic user values, for example on an author archive or user template.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0