UsersWP - Social Login <= 1.5.10 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'type' Shortcode Attribute
- ID
- WPSEC-2026-1937
- Plugin
- UsersWP – Social Login (userswp-social-login)
- Affected
- from 1.3.17 before 1.5.11
- Remediation
- Update to 1.5.11 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-29
- Attack surface
- UsersWP - Social Login on WPSec AttackSurface
- Fix released
- Published
Description
The UsersWP - Social Login plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'type' attribute of the [uwp_social] shortcode in all versions up to, and including, 1.5.10, due to insufficient input sanitization and output escaping. In the Bootstrap social login template, the value is only passed through sanitize_text_field(), which leaves double quotes intact. It is then concatenated into the Google sign-in button URL and printed unescaped inside an href attribute. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The script runs for logged-out visitors when Google login is enabled.
References
- https://wpsec.com/vuln/WPSEC-2026-1937/
- https://plugins.svn.wordpress.org/userswp-social-login/tags/1.5.11/
- https://wordpress.org/plugins/userswp-social-login/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS