Kit (formerly ConvertKit) – Email Newsletter, Email Marketing, Membership, Subscribers and Landing Pages <= 3.4.7 - Unauthenticated Sensitive Information Exposure via REST API, Feeds, Archives and WooCommerce Product Descriptions
- ID
- WPSEC-2026-1941
- Plugin
- Kit (formerly ConvertKit) – Email Newsletter, Email Marketing, Membership, Subscribers and Landing Pages (convertkit)
- Affected
- from 2.1.0 before 3.4.8
- Remediation
- Update to 3.4.8 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-200
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-29
- Attack surface
- Kit (formerly ConvertKit) – Email Newsletter, Email Marketing, Membership, Subscribers and Landing Pages on WPSec AttackSurface
- Fix released
- Published
Description
The Kit (formerly ConvertKit) plugin for WordPress is vulnerable to Sensitive Information Exposure via the Member Content feature in versions 2.1.0 up to, and including, 3.4.7. This is because Member Content restrictions were only applied when a single post, page or product was viewed. This makes it possible for unauthenticated attackers to read the full content of member-only posts, pages and WooCommerce products through other channels. These include the WordPress REST API (content.rendered), RSS and Atom feeds and their generated excerpts, archive, category and search result listings, and, when WooCommerce is active, product descriptions, short descriptions and variation descriptions exposed by the WooCommerce Store API and product blocks.
References
- https://wpsec.com/vuln/WPSEC-2026-1941/
- https://plugins.svn.wordpress.org/convertkit/tags/3.4.8/
- https://wordpress.org/plugins/convertkit/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS