Vulnerabilities / User Frontend / WPSEC-2026-1945

User Frontend <= 4.3.13 - Unauthenticated Privilege Escalation via Restricted Shortcode Injection

High 8.1 CWE-269Fixed in 4.3.14
ID
WPSEC-2026-1945
Plugin
User Frontend – Membership, User Registration, User Profile, User Directory & Content Restriction with Frontend Post Submission (wp-user-frontend)
Affected
all versions before 4.3.14
Remediation
Update to 4.3.14 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-269
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-29
Attack surface
User Frontend on WPSec AttackSurface
Fix released
Published

Description

The User Frontend plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 4.3.13. The restricted-shortcode check on frontend post submissions only covered rich-text fields and inspected text normalised differently from what was stored, allowing the protected [wpuf-registration] shortcode to slip through. This makes it possible for unauthenticated attackers, on forms that allow guest posting, and authenticated attackers with subscriber-level access and above, to embed the registration shortcode in a submission and use it to register a new account with a higher role such as Editor, provided user registration is enabled.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0