Vulnerabilities / User Frontend / WPSEC-2026-1948

User Frontend <= 4.3.13 - Authenticated (Subscriber+) Payment Bypass to Paid Subscription Pack Activation

Medium 4.3 CWE-840Fixed in 4.3.14
ID
WPSEC-2026-1948
Plugin
User Frontend – Membership, User Registration, User Profile, User Directory & Content Restriction with Frontend Post Submission (wp-user-frontend)
Affected
all versions before 4.3.14
Remediation
Update to 4.3.14 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-840
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-29
Attack surface
User Frontend on WPSec AttackSurface
Fix released
Published

Description

The User Frontend plugin for WordPress is vulnerable to a payment bypass in all versions up to, and including, 4.3.13, due to the PayPal gateway's free-checkout handling granting the submitted item ID as a subscription pack without checking the item type, while the missing form cost of a post-type payment resolves to zero. This makes it possible for authenticated attackers with subscriber-level access and above to activate a paid subscription pack without paying.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0