Vulnerabilities / User Frontend / WPSEC-2026-1949
User Frontend <= 4.3.13 - Missing Authorization to Settings Update via Setup Wizard
Medium 5.3
CWE-862Fixed in 4.3.14
- ID
- WPSEC-2026-1949
- Plugin
- User Frontend – Membership, User Registration, User Profile, User Directory & Content Restriction with Frontend Post Submission (wp-user-frontend)
- Affected
- all versions before 4.3.14
- Remediation
- Update to 4.3.14 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- Weakness
- CWE-862
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-29
- Attack surface
- User Frontend on WPSec AttackSurface
- Fix released
- Published
Description
The User Frontend plugin for WordPress is vulnerable to unauthorized modification of data in all versions up to, and including, 4.3.13 due to a missing capability check in the setup wizard, which runs on admin_init and therefore also on logged-out admin-ajax.php requests. This makes it possible for unauthenticated attackers to run the setup wizard steps and overwrite the plugin's payment, posting and profile settings, including the saved PayPal details.
References
- https://wpsec.com/vuln/WPSEC-2026-1949/
- https://plugins.svn.wordpress.org/wp-user-frontend/tags/4.3.14/
- https://wordpress.org/plugins/wp-user-frontend/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS